<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//cookie-cdn.cookiepro.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//cdn.steamboatpilot.com' /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link data-minify="1" rel='stylesheet' id='gtranslate-style-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/plugins/gtranslate/gtranslate-style24-96a400ab2c5b32770118e22378816e5c.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.steamboatpilot.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='wp-polls-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/plugins/wp-polls/polls-css-67618d6d860428870e0a6293ac4d693d.css' type='text/css' media='all' /><style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url(https://cdn.steamboatpilot.com/wp-content/plugins/wp-polls/images/default/pollbg.gif);border:1px solid #c8c8c8}</style><link rel='stylesheet' id='swift-main-css-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/busting/8/wp-content/themes/swift-news-theme/assets/css/main.min-1571944938.css' type='text/css' media='all' /><style id='swift-main-css-inline-css' type='text/css'>#layout-single article img{pointer-events:none;-webkit-user-select:none;-khtml-user-select:none;-moz-user-select:none;-o-user-select:none;user-select:none;-webkit-user-drag:none;-khtml-user-drag:none;-moz-user-drag:none;-o-user-drag:none;user-drag:none}</style><link rel='stylesheet' id='google-fonts-css-css'  href='https://fonts.googleapis.com/css?family=Heebo%3A400%2C700%7CLora%3A400%2C400i%2C700&#038;display=swap&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-css-css'  href='https://use.fontawesome.com/releases/v5.4.1/css/all.css?ver=5.0.13' type='text/css' media='all' /><link rel='stylesheet' id='weather-icons-css-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/busting/8/wp-content/themes/swift-news-theme/assets/css/vendors/weather-icons/weather-icons.min-2.0.css' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='bootstrap-calendar-css-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/css/vendors/bootstrap-datepicker/bootstrap-datepicker-674215b532672f98715ef4efd680e59d.css' type='text/css' media='all' /><link rel='stylesheet' id='fancybox-css-css'  href='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.css?ver=3.5.6' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='lightslider-css-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/css/vendors/lightslider-242b21aa0e7fafca6f7158622e8d0ecf.css' type='text/css' media='all' /><link data-minify="1" rel='stylesheet' id='lightgallery-css-css'  href='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/css/vendors/lightgallery-2599a9818387f73d9bf0d5c39146706a.css' type='text/css' media='all' /> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery/3.3.1/jquery.min.js?ver=3.3.1'></script> <script type='text/javascript'>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</script> <link rel='https://api.w.org/' href='https://www.steamboatpilot.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.steamboatpilot.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.steamboatpilot.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Maren’s Mercantile is open for business' href='https://www.steamboatpilot.com/news/marens-mercantile-is-open-for-business/' /><link rel='next' title='Ginsberg&#8217;s &#8216;Howl&#8217; sparks controversy in Steamboat schools' href='https://www.steamboatpilot.com/news/ginsbergs-howl-sparks-controversy-in-steamboat-schools/' /><meta name="generator" content="WordPress 5.2.4" /><link rel="canonical" href="https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/" /><link rel='shortlink' href='https://www.steamboatpilot.com/?p=356944' /><link rel="alternate" type="application/json+oembed" href="https://www.steamboatpilot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.steamboatpilot.com%2Fnews%2Fsuspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.steamboatpilot.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.steamboatpilot.com%2Fnews%2Fsuspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder%2F&#038;format=xml" /> <script>window.SGPMPopupLoader=window.SGPMPopupLoader||{ids:[],popups:{},call:function(w,d,s,l,id){
									w['sgp']=w['sgp']||function(){(w['sgp'].q=w['sgp'].q||[]).push(arguments[0]);};
									var sg1=d.createElement(s),sg0=d.getElementsByTagName(s)[0];
									if(SGPMPopupLoader && SGPMPopupLoader.ids && SGPMPopupLoader.ids.length > 0){SGPMPopupLoader.ids.push(id); return;}
									SGPMPopupLoader.ids.push(id);
									sg1.onload = function(){SGPMPopup.openSGPMPopup();}; sg1.async=true; sg1.src=l;
									sg0.parentNode.insertBefore(sg1,sg0);
									return {};
								}};</script><script>SGPMPopupLoader.call(window,document,'script','https://popupmaker.com/assets/lib/SGPMPopup.min.js','5c6d2736');SGPMPopupLoader.call(window,document,'script','https://popupmaker.com/assets/lib/SGPMPopup.min.js','1253a7d7');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-851550877"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'AW-851550877');</script>  <script>gtag('event', 'conversion', {'send_to': 'AW-851550877/FXboCPrZnacBEJ3FhpYD'});</script>  <script src="https://js.adsrvr.org/up_loader.1.1.0.js" type="text/javascript"></script> <script type="text/javascript">ttd_dom_ready( function() {
                if (typeof TTDUniversalPixelApi === 'function') {
                    var universalPixelApi = new TTDUniversalPixelApi();
                    universalPixelApi.init("eac6kka", ["0vwwwr2"], "https://insight.adsrvr.org/track/up");
                }
            });</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
          (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
          m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-381152-5', 'auto');
        ga('create', 'UA-4028663-63', 'auto', {'name': 'newTracker'});
 	      ga('require', 'displayfeatures');
	      ga('require', 'linkid');</script> <script>(function() {
			  var _fbq = window._fbq || (window._fbq = []);
			  if (!_fbq.loaded) {
			    var fbds = document.createElement('script');
			    fbds.async = true;
			    fbds.src = '//connect.facebook.net/en_US/fbds.js';
			    var s = document.getElementsByTagName('script')[0];
			    s.parentNode.insertBefore(fbds, s);
			    _fbq.loaded = true;
			  }
			  _fbq.push(['addPixelId', '356889104458573']);
			  
			  })();
			  window._fbq = window._fbq || [];
			  window._fbq.push(["track", "PixelInitialized", {}]);</script><noscript> <img height="1" width="1" border="0" alt="" style="display:none" src="https://www.facebook.com/tr?id=356889104458573&ev=PixelInitialized" /> </noscript><meta name="google-site-verification" content="E_HocH5khgpeWecqkoQZWhAGR1DAnF1Otk5SNN84CuU" /><meta name="__sync_contentCategory" content="Paid" /><meta name="__sync_tenantId" content="swc_gt"><link rel="shortcut icon" href="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/03/st-favicon.ico"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/03/st-apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/03/st-favicon-32x32.png"><title>Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder | SteamboatToday.com</title><meta name="description" content="STEAMBOAT SPRINGS — The three people arrested for the murder of 26-year-old Steamboat Springs man Elliot Stahl were officially charged with three felonies and one misdemeanor late Friday afternoon by District Attorney Matt Karzen. William..." /><meta name="keywords" content="STAHL, ELLIOT, ELLIFRITZ, Forquer, Piccolo-Labbs, steamboat, MURDER, DEATH, FATALITY, MAN, BODY, COLORADO" /><meta property="og:title" content="Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder"/><meta property="og:description" content="STEAMBOAT SPRINGS — The three people arrested for the murder of 26-year-old Steamboat Springs man Elliot Stahl were officially charged with three felonies and one misdemeanor late Friday afternoon by District Attorney Matt Karzen. William..."/><meta property="og:url" content="https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@steamboatpilot"/><meta property="og:image" content="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="581" /><meta name="twitter:image" content="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg" /><meta name="sniply-options" content="block" /><meta property="article:publisher" content="https://www.facebook.com/SteamboatPilot" /><meta property="article:author" content="https://www.facebook.com/lisa.n.schlichtman" /><meta name="author" content="Lisa Schlichtman" /><meta property="og:type" content="article" /> <script type="application/ld+json">{
				  "@context": "https://schema.org",
				  "@type": "NewsArticle",
				  "mainEntityOfPage": {
				    "@type": "WebPage",
				    "@id": "https://google.com/article"
				  },
					
				  "headline": "Suspects officially charged with 3 felonies in connection with Steamboat man&amp;#8217;s murder",
				  "image": [
				    "https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg"
				   ],
				  "datePublished": "2019-10-28 13:54:59",
				  "dateModified": "2019-10-28 15:00:29",
					"author": {
						"@type": "Person",
						"name": "Lisa Schlichtman"
					},
				   "publisher": {
				    "@type": "Organization",
				    "name": "SteamboatToday.com",
				    "logo": {
				      "@type": "ImageObject",
				      "url": "https://www.steamboatpilot.com/wp-content/uploads/sites/8/2019/08/st-logo-2x.png"
				    }
				  },
				  "description": "STEAMBOAT SPRINGS — The three people arrested for the murder of 26-year-old Steamboat Springs man Elliot Stahl were officially charged with three felonies and one misdemeanor late Friday afternoon by District Attorney Matt Karzen. William Clive Ellifritz, 26, Brooke L. Forquer, 21, and Skyla Marie Piccolo-Labbs, 23, all of Craig, each face one count of&hellip;"
				}</script><meta property="fb:app_id" content="410429292671862" /><meta name="pubdate" content="20191028"><style type="text/css" id="wp-custom-css"></style></head><body class="post-template-default single single-post postid-356944 single-format-standard steamboattoday category-crime-courts category-news"><div id="fb-root"></div> <script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=410429292671862&autoLogAppEvents=1';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script> <script>function get_cookie_value(a) {
					var b = document.cookie.match('(^|;)\\s*' + a + '\\s*=\\s*([^;]+)');
					return b ? b.pop() : '';
				}
				var free_site = true;
var show_survey = true;
				var syncwall_cookie = get_cookie_value('syncwall-active-subscriber');

				if ( syncwall_cookie !== null ) {
					//console.log('SwiftDebug | js free_site: ' + free_site );
					//console.log('SwiftDebug | js show_survey: ' + show_survey );
					//console.log('SwiftDebug | js syncwall-active-subscriber cookie value: ' + syncwall_cookie );
				}</script> <script>if ( (free_site === true && show_survey === true) || (free_site === false && ( show_survey === true && (syncwall_cookie !== null && syncwall_cookie !== "true") ) ) ) {

	        console.log("SwiftDebug | Google Survey enabled");

					(function() {
	          var ARTICLE_URL = window.location.href;
	          var CONTENT_ID = 'everything';
	          document.write(
	            '<scr'+'ipt '+
	            'src="//survey.g.doubleclick.net/survey?site=_fuv4zkode3grk'+
	            '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	            '&amp;random='+(new Date).getTime()+
	            '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	        })();

	      }
	      else {
	        console.log("SwiftDebug | Google Survey disabled");
	      }</script> <header><nav id="nav-publication" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"> <a class="logo navbar-brand" href="https://www.steamboatpilot.com"> <img  src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/08/st-logo.png" srcset="https://www.steamboatpilot.com/wp-content/uploads/sites/8/2019/08/st-logo-2x.png 2x" alt="SteamboatToday.com Logo"> </a><div class="align-self-end"> <span class="tag-line navbar-text">Serving Routt County, Colorado</span></div></div><div class="d-flex"><form class="search-form form-inline" action="https://www.steamboatpilot.com/search-results/"> <input class="search-input form-control" type="search" placeholder="Search" aria-label="Search" name="q"> <button class="search-button" type="submit"><i class="fas fa-search"></i></button> <input type="hidden" name="range" value="11/07/1991" /></form><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="/forecast/"> <i class="wi wi-cloudy"></i> 24&deg; </a></li></ul></div></nav><nav id="nav-main" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"><div id="nav-main-menu"><ul class="nav-menu navbar-nav"><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-4" href="https://www.steamboatpilot.com/">News</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-4" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/business/">Business</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/special-sections/">Special Sections</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/crime-courts/">Crime</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/real-estate/">Real estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/real-estate/housing/">Housing</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/health/">Health</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/education/">Education</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/marijuana/">Marijuana</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/calendar/#!/">Happenings</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/milestones/">Milestones</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-3162" href="https://www.steamboatpilot.com/milestones/obituaries/">Obituaries</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-3162" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/milestones/obituaries/">Latest obituaries</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://marketplace.adpay.com/CMNM/Obituary">Submit an obituary</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-3148" href="https://www.steamboatpilot.com/opinion/">Opinion</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-3148" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/opinion/letters-to-the-editor/">Letters to the editor</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/opinion/our-view-editorials/">Our View editorials</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/opinion/op-ed/">Guest commentary</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-3150" href="https://www.steamboatpilot.com/explore-steamboat/">Explore Steamboat</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-3150" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/20-under-40/">20 Under 40</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/calendar/">Happenings</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/arts/">Arts</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/entertainment/">Entertainment</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/food-drink/">Food and drink</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/steamboat-springs-happy-hours/">Happy Hours</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/best-of-the-boat-2018/">Best of the Boat</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=de791335-0be0-4fc5-8ac9-b75ad98a86ba">Explore Steamboat</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=b8afed0b-1ee8-4f45-983a-abfc2df867f8">Move to Steamboat</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://local.steamboatpilot.com/">Business directory</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-3154" href="https://www.steamboatpilot.com/sports-outdoors/">Sports &#038; Outdoors</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-3154" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/sports-outdoors/outdoors/">Outdoors</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/sports-outdoors/snow-sports/">Snow sports</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/sports-outdoors/prep-sports/">Prep sports</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/Launch.aspx?EID=622a0849-62a6-46ea-8044-9a556dacb9f6">Colorado Hunter</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=9b5ab08b-7af9-4291-b8c3-25e2ecbf061d">Bike Guide</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-334567" href="#">In Depth</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-334567" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/annexation/">West Steamboat annexation</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/health/longevity-event/">2018 Longevity Project: Blue Zones</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/health/longevity2019/">2019 Longevity Project: Thriving at Altitude</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/election/">Election</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/sports-outdoors/adventure-show/">Adventure Show</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/business/winter-heroes/%20">Winter Heroes</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/news/in-our-shoes/">In Our Shoes</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-334568" href="#">Videos & Photos</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-334568" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/video/">Video</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/webcams/">Mountain cams</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/photos/galleries/">Photo galleries</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-334569" href="https://www.steamboatpilot.com/explore-steamboat/calendar/%20">Happenings Calendar</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-334569" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.steamboatpilot.com/explore-steamboat/calendar/">See events</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://portal.cityspark.com/EventEntry/EventEntry/SteamboatToday">Add an event</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-334570" href="http://classifieds.steamboatpilot.com/">Classifieds</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-334570" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.steamboatpilot.com/category/Employment">Jobs</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.steamboatpilot.com/category/Real-Estate-For-Sale">Real estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=4fc5367b-e72d-444b-9cc3-a767f1ba9727">Homefinder</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.steamboatpilot.com/category/Transportation">Autos</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://secure.adpay.com/AdEntry.aspx?p=9136">Place ad</a></li></ul></li></ul></div></div><div class="d-flex"></div></nav><nav id="nav-mobile" class="d-lg-none d-xl-none py-1 shadow-sm"><div class="d-flex justify-content-between align-items-center"><div class="m-3"> <button class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"> <i class="fas fa-bars mr-1"></i> <i class="fas fa-times mr-1"></i> </button></div><div class="logo"> <a class="navbar-brand" href="https://www.steamboatpilot.com"> <img  src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/08/st-logo.png" srcset="https://www.steamboatpilot.com/wp-content/uploads/sites/8/2019/08/st-logo-2x.png 2x" alt="SteamboatToday.com Logo"> </a></div><div class="m-3"> <button class="search-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-search" aria-controls="nav-mobile-search" aria-expanded="false" aria-label="Toggle search"> <i class="fas fa-search ml-1"></i> <i class="fas fa-times mr-1"></i> </button></div></div></nav><nav id="nav-mobile-menu" class="hamburger-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-4" aria-expanded="false"> <span>News</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-4" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.steamboatpilot.com/">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/business/" >Business </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/special-sections/" >Special Sections </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/crime-courts/" >Crime </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/real-estate/" >Real estate </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/real-estate/housing/" >Housing </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/health/" >Health </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/education/" >Education </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/marijuana/" >Marijuana </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/calendar/#!/" >Happenings </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/milestones/" >Milestones </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-3162" aria-expanded="false"> <span>Obituaries</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-3162" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.steamboatpilot.com/milestones/obituaries/">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/milestones/obituaries/" >Latest obituaries </a></li><li><a class="nav-link infant" href="https://marketplace.adpay.com/CMNM/Obituary" >Submit an obituary </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-3148" aria-expanded="false"> <span>Opinion</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-3148" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.steamboatpilot.com/opinion/">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/opinion/letters-to-the-editor/" >Letters to the editor </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/opinion/our-view-editorials/" >Our View editorials </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/opinion/op-ed/" >Guest commentary </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-3150" aria-expanded="false"> <span>Explore Steamboat</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-3150" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.steamboatpilot.com/explore-steamboat/">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/20-under-40/" >20 Under 40 </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/calendar/" >Happenings </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/arts/" >Arts </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/entertainment/" >Entertainment </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/food-drink/" >Food and drink </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/steamboat-springs-happy-hours/" >Happy Hours </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/best-of-the-boat-2018/" >Best of the Boat </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=de791335-0be0-4fc5-8ac9-b75ad98a86ba" >Explore Steamboat </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=b8afed0b-1ee8-4f45-983a-abfc2df867f8" >Move to Steamboat </a></li><li><a class="nav-link infant" href="http://local.steamboatpilot.com/" >Business directory </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-3154" aria-expanded="false"> <span>Sports &#038; Outdoors</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-3154" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.steamboatpilot.com/sports-outdoors/">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/sports-outdoors/outdoors/" >Outdoors </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/sports-outdoors/snow-sports/" >Snow sports </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/sports-outdoors/prep-sports/" >Prep sports </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/Launch.aspx?EID=622a0849-62a6-46ea-8044-9a556dacb9f6" >Colorado Hunter </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=9b5ab08b-7af9-4291-b8c3-25e2ecbf061d" >Bike Guide </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-334567" aria-expanded="false"> <span>In Depth</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-334567" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="#">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/annexation/" >West Steamboat annexation </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/health/longevity-event/" >2018 Longevity Project: Blue Zones </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/health/longevity2019/" >2019 Longevity Project: Thriving at Altitude </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/election/" >Election </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/sports-outdoors/adventure-show/" >Adventure Show </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/business/winter-heroes/%20" >Winter Heroes </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/news/in-our-shoes/" >In Our Shoes </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-334568" aria-expanded="false"> <span>Videos & Photos</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-334568" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="#">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/video/" >Video </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/webcams/" >Mountain cams </a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/photos/galleries/" >Photo galleries </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-334569" aria-expanded="false"> <span>Happenings Calendar</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-334569" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.steamboatpilot.com/explore-steamboat/calendar/%20">View Section ></a></li><li><a class="nav-link infant" href="https://www.steamboatpilot.com/explore-steamboat/calendar/" >See events </a></li><li><a class="nav-link infant" href="https://portal.cityspark.com/EventEntry/EventEntry/SteamboatToday" >Add an event </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-334570" aria-expanded="false"> <span>Classifieds</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-334570" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="http://classifieds.steamboatpilot.com/">View Section ></a></li><li><a class="nav-link infant" href="http://classifieds.steamboatpilot.com/category/Employment" >Jobs </a></li><li><a class="nav-link infant" href="http://classifieds.steamboatpilot.com/category/Real-Estate-For-Sale" >Real estate </a></li><li><a class="nav-link infant" href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&edid=4fc5367b-e72d-444b-9cc3-a767f1ba9727" >Homefinder </a></li><li><a class="nav-link infant" href="http://classifieds.steamboatpilot.com/category/Transportation" >Autos </a></li><li><a class="nav-link infant" href="https://secure.adpay.com/AdEntry.aspx?p=9136" >Place ad </a></li></ul></div></li><style type="text/css">#goog-gt-tt{display:none!important}.goog-te-banner-frame{display:none!important}.goog-te-menu-value:hover{text-decoration:none!important}.goog-text-highlight{background-color:transparent!important;box-shadow:none!important}body{top:0!important}#google_translate_element2{display:none!important}</style><div id="google_translate_element2"></div> <script type="text/javascript">function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}</script> <script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script> <script type="text/javascript">function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
				function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
				function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(/goog-te-combo/.test(sel[i].className)){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}</script> <li class="nav-item"><a class="nav-link translate-link english glink nturl" type="button" onclick="doGTranslate('en|en');return false;" title="English" href="#"><span>English</span></a></li><li class="nav-item"><a class="nav-link translate-link spanish glink nturl" type="button" onclick="doGTranslate('en|es');return false;" title="Spanish" href="#"><span>Spanish</span></a></li></ul></nav><div id="nav-mobile-search" class="search-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><form class="search-form form-inline d-flex" action="https://www.steamboatpilot.com/search-results/"> <input class="search-input form-control flex-fill" type="search" aria-label="Search" name="q" placeholder="enter search terms"> <button class="search-button btn" type="submit">Search</button> <input type="hidden" name="range" value="11/07/1991" /></form></div></header><main><div class="container"><nav id="nav-reader-tools" class="navbar navbar-expand d-none d-lg-flex"><ul class="nav-menu navbar-nav ml-auto"><li id="menu-item-334612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334612"><a href="http://www.swiftlocalsolutions.com/advertise-with-steamboat-today">Advertise</a><span>|</span></li><li id="menu-item-334613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334613"><a target="_blank" rel="noopener noreferrer" href="https://www.steamboatpilot.com/eedition/">E-edition</a><span>|</span></li><li id="menu-item-334614" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334614"><a href="https://www.steamboatpilot.com/contribute/">Contribute</a><span>|</span></li><li id="menu-item-334888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334888"><a href="https://www.steamboatpilot.com/contact-us/">Contact Us</a><span>|</span></li><style type="text/css">#goog-gt-tt{display:none!important}.goog-te-banner-frame{display:none!important}.goog-te-menu-value:hover{text-decoration:none!important}.goog-text-highlight{background-color:transparent!important;box-shadow:none!important}body{top:0!important}#google_translate_element2{display:none!important}</style><div id="google_translate_element2"></div> <script type="text/javascript">function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}</script> <script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script> <script type="text/javascript">function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
				function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
				function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(/goog-te-combo/.test(sel[i].className)){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}</script> <li><a href="#" class="translate-link english glink nturl" onclick="doGTranslate('en|en');return false;" title="English"><img  src="https://cdn.steamboatpilot.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="12" width="12" alt="English" />English</a><span>|</span></li><li><a href="#" class="translate-link spanish glink nturl" onclick="doGTranslate('en|es');return false;" title="Spanish"><img  src="https://cdn.steamboatpilot.com/wp-content/plugins/gtranslate/flags/24/es.png" height="12" width="12" alt="Spanish" />Spanish</a></li></ul></nav><div id="primary"><div class="container-fluid" style="margin-bottom: 20px;"><div class="row justify-content-center"><div id="ad-top" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-top');
				})</script> </div></div></div><div id="layout-single"><div class="d-lg-flex"><article class="flex-fill"><h1>Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder</h1><div id="article-meta"><div class="row no-gutters"><div class="col-auto"><p class="article-meta"><a href="https://www.steamboatpilot.com/recent-stories/news">News</a> <span class="text-muted">| October 28, 2019</span> <a id="mobile-app-link" href="#" style="display:block;margin:5px 0 0 0;color:#0645ad;"></a> <script>function androidOrIOS() {
					const userAgent = navigator.userAgent;
					const applink = document.getElementById('mobile-app-link');
					const whizDeepLink = 'steamboattodaymobile://content?url=https%3A%2F%2Fwww.steamboatpilot.com%2Fnews%2Fsuspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder%2F&sectionId=&fallback=1';

					if ( whizDeepLink != '' && /iPad|iPhone|iPod/i.test(userAgent) ) {
						applink.href = whizDeepLink;
						applink.innerHTML = '<i class="fas fa-mobile-alt"></i> View in mobile app';
						applink.title = 'Whiz';
					}
					else {
						if (/android/i.test(userAgent)){
							applink.href = 'https://play.google.com/store/apps/details?id=com.steamboattoday.android&hl=en_US';
							applink.innerHTML = '<i class="fas fa-mobile-alt"></i> Open mobile app';
							applink.title = 'Andriod';
						}
						else if(/iPad|iPhone|iPod/i.test(userAgent)){
							applink.href = 'https://apps.apple.com/us/app/steamboat-pilot-today/id482636924';
							applink.innerHTML = '<i class="fas fa-mobile-alt"></i> Open mobile app';
							applink.title = 'iOS';
						}

					}

				}
				androidOrIOS();</script> </p></div><div class="col"><div class="d-lg-none"><div class="article-social"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder&url=https://www.steamboatpilot.com/?p=356944" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=410429292671862&href=https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item"> <a class="nav-link fb-counter-link" href="https://www.facebook.com/dialog/share?app_id=410429292671862&href=https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/" target="_blank"><span class="fb-counter">11</span></a></li><li class="nav-item"> <a class="nav-link" href="mailto:?subject=Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder&body=STEAMBOAT SPRINGS — The three people arrested for the murder of 26-year-old Steamboat Springs man Elliot Stahl were officially charged with three felonies and one misdemeanor late Friday afternoon by District Attorney Matt Karzen. William...%0D%0A%0D%0Ahttps://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div></div></div><div id="article-byline"><div class="d-flex"><div class="editor-image"><img src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2017/04/072313_Schlichtman_t180-150x150.jpg" alt="Lisa Schlichtman" /></div><div class="editor-name"><h6><a href="https://www.steamboatpilot.com/profile/lisa-schlichtman/" rel="author">Lisa Schlichtman</a></h6><p><a href="mailto:lschlichtman@SteamboatPilot.com" rel="author">lschlichtman@SteamboatPilot.com</a></p></div><div class="d-none d-lg-block ml-auto"><div class="article-social"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder&url=https://www.steamboatpilot.com/?p=356944" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=410429292671862&href=https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item"> <a class="nav-link fb-counter-link" href="https://www.facebook.com/dialog/share?app_id=410429292671862&href=https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/" target="_blank"><span class="fb-counter">11</span></a></li><li class="nav-item"> <a class="nav-link" href="mailto:?subject=Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder&body=STEAMBOAT SPRINGS — The three people arrested for the murder of 26-year-old Steamboat Springs man Elliot Stahl were officially charged with three felonies and one misdemeanor late Friday afternoon by District Attorney Matt Karzen. William...%0D%0A%0D%0Ahttps://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div></div><div class="p402_premium"><figure class="wp-block-image p402_hide"><div class="caption-container"> <img width="1024" height="581" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg" class="attachment-large size-large wp-post-image" alt="" data-lazy-srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg 1024w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-300x170.jpeg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-768x436.jpeg 768w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat.jpeg 1050w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" /><noscript><img width="1024" height="581" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg" class="attachment-large size-large wp-post-image" alt="" srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-1024x581.jpeg 1024w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-300x170.jpeg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-768x436.jpeg 768w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat.jpeg 1050w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><figcaption><strong>Brooke L. Forquer, William C. Ellifritz and Skyla M. Piccolo-Laabs</strong><br /><em></em></figcaption></div></figure><p>STEAMBOAT SPRINGS — The three people arrested for the murder of 26-year-old Steamboat Springs man Elliot Stahl were officially charged with three felonies and one misdemeanor late Friday afternoon by District Attorney Matt Karzen.</p><p>William Clive Ellifritz, 26, Brooke L. Forquer, 21, and Skyla Marie Piccolo-Labbs, 23, all of Craig, each face one count of murder in the first degree, a Class 1 felony, along with one count of aggravated robbery, a Class 3 felony, and one count of conspiracy to commit robbery, a Class 5 felony. They also were charged with one count of abuse of a corpse, a misdemeanor.</p><p>The three <a href="https://www.steamboatpilot.com/news/3-people-arrested-in-death-of-26-year-old-steamboat-man/">were arrested</a> Oct. 19 and <a href="https://www.steamboatpilot.com/news/judge-rules-no-bond-for-suspects-in-murder-of-steamboat-man-pending-the-filing-of-formal-charges/">are being held without bond</a> in the Routt County Jail.</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-parallax2" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-parallax2');
				})</script> </div></div></div><p>According to complaints filed by the district attorney&#8217;s office, the three defendants have been accused of causing the death of Stahl and stealing money, a backpack and prescription medications from him.</p><p>In an arrest affidavit filed in the case, Piccolo-Labbs told an agent with the Colorado Bureau of Investigation that Ellifritz stabbed Stahl in the neck with a knife, then both Forquer and Piccolo-Labbs, in separate interviews with the agent, said Ellifritz made them stab Stahl. Piccolo-Labbs told the agent she believed Ellifritz had&nbsp;them stab Stahl “to make them partially responsible.”</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-big-box4" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-big-box4');
				})</script> </div></div></div><p>The alleged stabbing occurred Oct. 13 on U.S. Highway 40, somewhere between Mount Werner Road and Rabbit Ears Pass, while the three suspects and Stahl were riding in a car driven by Forquer, according to the affidavit.</p><p>Stahl’s body was discovered Oct. 14 on Forest Service Road 900 south of Yampa by a man fishing in the Flat Tops Wilderness Area. According to the arrest affidavit, when law enforcement officers arrived, they noticed the body looked as if had been placed at the scene with drag marks visible on the two-track road.</p><p>The arrest affidavit also indicated that Stahl’s body had a stab wound to the neck and to the upper chest, according to Detective TJ Sisto of the Routt County Sheriff&#8217;s Office, who attended Stahl’s autopsy.</p><p>The case was investigated by the sheriff’s office with assistance from the Colorado Bureau of Investigation, Craig Police Department, Steamboat Springs Police Department, Moffat County Sheriff’s Office and the 14th Judicial District Attorney’s Office.&nbsp;</p><p>Piccolo-Laabs, Forquer and Ellifritz are scheduled for bond hearings at 1:30 p.m. Tuesday, Oct. 29.</p><p><em>To reach Lisa Schlichtman, call 970-871-4221, email <a href="mailto:lschlichtman@SteamboatPilot.com">lschlichtman@SteamboatPilot.com</a> or follow her on Twitter <a href="https://twitter.com/lschlichtman">@lschlichtman</a></em>.</p><p class="article-tagline"><em></em></p></div> <script type="text/javascript">try { _402_Show(); } catch(e) {}</script> <hr /><div id="fb-comment-policy"><p>Start a dialogue, stay on topic and be civil.<br /> If you don't <a href="https://www.steamboatpilot.com/comment-policy">follow the rules</a>, your comment may be deleted.</p></div><div class="fb-comments" data-href="https://www.steamboatpilot.com/?p=356944" data-width="100%" data-numposts="3"></div><hr /><div id="single-flipp-script"><div id="circularhub_module_15504"></div> <script src="//api.circularhub.com/15504/c6fea42ec1f276a6/circularhub_module.js"></script> </div><hr /><div class="row"><div class="card-item col-md-12"><div class="module module-dual-column card shadow-sm"><div class="card-header"><i class="far fa-newspaper icon-section"></i> Crime &amp; Courts</div><div class="card-body"><section><article><div class="row no-gutters"><div class="col-12 col-lg-5 card-img featured text-center"> <a href="https://www.steamboatpilot.com/news/violent-fugitive-arrested-at-steamboat-construction-site/"><img width="300" height="238" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/Garcia-Rivera-Arrest-2-300x238.jpg" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/Garcia-Rivera-Arrest-2-300x238.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/Garcia-Rivera-Arrest-2.jpg 390w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="238" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/Garcia-Rivera-Arrest-2-300x238.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/Garcia-Rivera-Arrest-2-300x238.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/Garcia-Rivera-Arrest-2.jpg 390w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="col-12 col-lg-7 card-text"><h4><a href="https://www.steamboatpilot.com/news/violent-fugitive-arrested-at-steamboat-construction-site/">&#8216;Violent&#8217; fugitive arrested at Steamboat construction site</a></h4><p class="card-meta"><span class="text-muted">October 29, 2019</span></p><p class="card-excerpt d-lg-none d-xl-block"></p></div></div></article><hr /><div class="row"><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.steamboatpilot.com/news/cat-bite-the-record-for-sunday-oct-27-2019/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg 150w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-300x300.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-100x100.jpg 100w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg 150w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-300x300.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.steamboatpilot.com/news/cat-bite-the-record-for-sunday-oct-27-2019/">Cat bite: The Record for Sunday, Oct. 27, 2019</a></h6><p class="card-meta"><span class="text-muted">October 28, 2019</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-150x150.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /><noscript><img width="150" height="150" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/10/cat-150x150.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.steamboatpilot.com/news/suspects-officially-charged-with-3-felonies-in-connection-with-steamboat-mans-murder/">Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder</a></h6><p class="card-meta"><span class="text-muted">October 28, 2019</span></p></div></div></article><hr class="d-md-none d-lg-none d-xl-none" /></div><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.steamboatpilot.com/news/bear-destroys-trash-can-the-record-for-saturday-oct-27-2019/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg 150w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-300x300.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-100x100.jpg 100w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg 150w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-300x300.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.steamboatpilot.com/news/bear-destroys-trash-can-the-record-for-saturday-oct-27-2019/">Bear destroys trash can: The Record for Saturday, Oct. 26, 2019</a></h6><p class="card-meta"><span class="text-muted">October 27, 2019</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.steamboatpilot.com/news/two-bears-stuck-inside-dumpster-the-record-for-friday-oct-25-2019/"><img width="150" height="150" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg 150w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-300x300.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-100x100.jpg 100w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" /><noscript><img width="150" height="150" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-150x150.jpg 150w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-300x300.jpg 300w, https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2018/04/The-Record_logo-100x100.jpg 100w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.steamboatpilot.com/news/two-bears-stuck-inside-dumpster-the-record-for-friday-oct-25-2019/">Two bears stuck inside dumpster: The Record for Friday, Oct. 25, 2019</a></h6><p class="card-meta"><span class="text-muted">October 26, 2019</span></p></div></div></article></div></div><hr /></section> <a href="https://www.steamboatpilot.com/recent-stories/crime-courts/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div></div></article><aside><div class="card-container row"><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-gallery module-c2 card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Top Jobs</h5><div id="carousel-334607" class="carousel slide" data-ride="carousel" data-interval="5000"><div class="carousel-inner"><div class="carousel-item active" style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Restaurant-Clubs/souf-chef-and-line-cook-catamount-ranch-and-club-steamboat-springs/8-0000502754-01" target="_blank">Catamount Ranch & Club</a></h5><h6>Souf Chef & Line Cook at Catamount Ranch & Club in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>SOUS CHEF&#58; Full-time year-round, includes excellent health benefits, $1000 recreation benefit, lake&#47;golf privileges, annual bonus.&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Health-Care/full-time-clinical-addiction-technician-the-foundry-steamboat-springs/8-0000494182-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000216020-01-0.jpg" alt="Full time Clinical  Addiction Technician at The Foundry in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Health-Care/full-time-clinical-addiction-technician-the-foundry-steamboat-springs/8-0000494182-01" target="_blank">The Foundry</a></h5><h6>Full time Clinical  Addiction Technician at The Foundry in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Full time Clinical Addiction Technician Provide support, assistance and hope to clients engaging in treatment&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Trades-Construction/snow-removal-equipment-operators-front-end-loaders-skidsteers-rocky-mountain-asphalt-steamboat-springs/8-0000492600-01" target="_blank">Rocky Mountain Asphalt</a></h5><h6>Snow removal Equipment Operators, Front End Loaders, Skidsteers at Rocky Mountain Asphalt in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Rocky Mountain Asphalt is looking for Snow Removal Equipment Operators Front End Loaders Skidsteers 2&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Trades-Construction/mining-positions-at-jennmar-in-craig-jennmar-services-craig/8-0000496774-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000496774-01.jpg" alt="Mining positions at Jennmar in Craig  at Jennmar Services  in CRAIG" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Trades-Construction/mining-positions-at-jennmar-in-craig-jennmar-services-craig/8-0000496774-01" target="_blank">Jennmar Services </a></h5><h6>Mining positions at Jennmar in Craig  at Jennmar Services  in CRAIG</h6><p style="font-size:.875rem;"> <em></em><br><span></span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Hospitality/multiple-hospitality-jobs-the-porches-steamboat-springs/8-0000500535-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_21228561.jpg" alt="Multiple Hospitality Jobs at The Porches in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Hospitality/multiple-hospitality-jobs-the-porches-steamboat-springs/8-0000500535-01" target="_blank">The Porches</a></h5><h6>Multiple Hospitality Jobs at The Porches in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>The Porches of Steamboat is looking for motivated, detail oriented, self starters that are looking&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Drivers/driver-residential-waste-management-steamboat-springs/8-0000498373-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000235157-01-0.jpg" alt="Driver Residential at Waste Management in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Drivers/driver-residential-waste-management-steamboat-springs/8-0000498373-01" target="_blank">Waste Management</a></h5><h6>Driver Residential at Waste Management in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>IS HIRING Driver Residential (Non-Experienced) (19016364) Great benefits and competitive pay! Apply online at www.wm.com&#47;careers&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Trades-Construction/well-rounded-carpenter-small-contractor-steamboat-springs/8-0000499092-01" target="_blank">Small Contractor</a></h5><h6>Well Rounded Carpenter at Small Contractor in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Small contractor looking for&#58; Well Rounded Carpenter full time, Pay DOE Marc&#58; 970-846-0218</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Building-Services/custodian-evening-position-east-grand-school-district-granby/8-0000498269-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000110648-01-0.jpg" alt="Custodian - Evening Position at East Grand School District in GRANBY" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Building-Services/custodian-evening-position-east-grand-school-district-granby/8-0000498269-01" target="_blank">East Grand School District</a></h5><h6>Custodian - Evening Position at East Grand School District in GRANBY</h6><p style="font-size:.875rem;"> <em></em><br><span>CUSTODIAN Evening Position Starting pay $14.25 to $15.55 Depending on education &amp; experience. Benefits&#58; 10&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Professional/office-assistant-pool-attendant-laborers-strawberry-hot-springs-steamboat-springs/8-0000502259-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000176162-01-0.jpg" alt="Office Assistant, Pool Attendant, Laborers at Strawberry Hot Springs in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Professional/office-assistant-pool-attendant-laborers-strawberry-hot-springs-steamboat-springs/8-0000502259-01" target="_blank">Strawberry Hot Springs</a></h5><h6>Office Assistant, Pool Attendant, Laborers at Strawberry Hot Springs in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Strawberry Hot Springs Is seeking an&#58; Office Assistant Pool Attendant Laborers Pay Negotiable, DOE Please&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Sales-Marketing/salesproject-management-ced-steamboat-springs/8-0000503285-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000273308-01-0.jpg" alt="Sales/Project Management at CED in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Sales-Marketing/salesproject-management-ced-steamboat-springs/8-0000503285-01" target="_blank">CED</a></h5><h6>Sales/Project Management at CED in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Currently hiring for&#58; FT &amp; PT Sales&#47;PM&#47; Operations&#47;Clerical Steamboat Springs, CO WILL TRAIN RIGHT PERSON&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Sales-Marketing/biz-ops-and-booking-agents-positions-now-open-wyndham-destinations-steamboat-springs/8-0000501557-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_21212270.jpg" alt="Biz Ops and Booking Agents positions now open! at Wyndham Destinations in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Sales-Marketing/biz-ops-and-booking-agents-positions-now-open-wyndham-destinations-steamboat-springs/8-0000501557-01" target="_blank">Wyndham Destinations</a></h5><h6>Biz Ops and Booking Agents positions now open! at Wyndham Destinations in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Biz Ops and Booking Agents positions now open! We have immediate Full Time, Year Round,&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Hospitality/winter-hospitality-positions-one-steamboat-place-steamboat-springs/8-0000500165-01" target="_blank">One Steamboat Place</a></h5><h6>Winter Hospitality Positions  at One Steamboat Place in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>Join our amazing team this winter, working at a world class resort at the base&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Government/park-and-recreation-director-city-of-craig-craig/8-0000501970-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000501970-01-0.jpg" alt="Park & Recreation Director at City of CRaig in CRAIG" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Government/park-and-recreation-director-city-of-craig-craig/8-0000501970-01" target="_blank">City of CRaig</a></h5><h6>Park & Recreation Director at City of CRaig in CRAIG</h6><p style="font-size:.875rem;"> <em></em><br><span>City of Craig is looking for a Parks &amp; Recreation Director. Parks&#47;Recreation Dept. $82,489 -&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.steamboatpilot.com/ad/Employment/Media/news-designer-steamboat-pilot-and-today-steamboat-springs/8-0000500382-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="https://classifieds.steamboatpilot.com/data/thumbnails/t_0000500382-01.jpg" alt="News Designer at Steamboat Pilot & Today in STEAMBOAT SPRINGS" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></a><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Media/news-designer-steamboat-pilot-and-today-steamboat-springs/8-0000500382-01" target="_blank">Steamboat Pilot & Today</a></h5><h6>News Designer at Steamboat Pilot & Today in STEAMBOAT SPRINGS</h6><p style="font-size:.875rem;"> <em></em><br><span>News Designer The Steamboat Pilot &amp; Today seeks a news designer with strong copynediting and&hellip;</span></p></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:280px;float:left;"><h5><a href="http://classifieds.steamboatpilot.com/ad/Employment/Drivers/laborers-and-cdl-drivers-granby-sand-and-gravel-granby/8-0000499040-01" target="_blank">Granby Sand and Gravel</a></h5><h6> Laborers, and CDL Drivers at Granby Sand and Gravel in GRANBY</h6><p style="font-size:.875rem;"> <em></em><br><span>ATH Specialties is currently seeking , Laborers, and CDL Drivers. Please contact Brittany @ 970-531-2926.</span></p></div></div></div><div class="carousel-nav d-flex justify-content-center"><a class="carousel-control-prev position-absolute" style="width:60px;height:40px;top:100px;left:-30px;" href="#carousel-334607" role="button" data-slide="prev"> <i class="fas fa-chevron-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#carousel-334607" data-slide-to="1" class="active"></li><li data-target="#carousel-334607" data-slide-to="2" class=""></li><li data-target="#carousel-334607" data-slide-to="3" class=""></li><li data-target="#carousel-334607" data-slide-to="4" class=""></li><li data-target="#carousel-334607" data-slide-to="5" class=""></li><li data-target="#carousel-334607" data-slide-to="6" class=""></li><li data-target="#carousel-334607" data-slide-to="7" class=""></li><li data-target="#carousel-334607" data-slide-to="8" class=""></li><li data-target="#carousel-334607" data-slide-to="9" class=""></li><li data-target="#carousel-334607" data-slide-to="10" class=""></li><li data-target="#carousel-334607" data-slide-to="11" class=""></li><li data-target="#carousel-334607" data-slide-to="12" class=""></li><li data-target="#carousel-334607" data-slide-to="13" class=""></li><li data-target="#carousel-334607" data-slide-to="14" class=""></li><li data-target="#carousel-334607" data-slide-to="15" class=""></li></ol><a class="carousel-control-next position-absolute" style="width:60px;height:40px;top:100px;right:-30px;" href="#carousel-334607" role="button" data-slide="next"> <i class="fas fa-chevron-right"></i> <span class="sr-only">Next</span> </a></div></div><hr /><a href="http://classifieds.steamboattoday.com/category/Employment" class="card-link card-more" target="_blank">View more listings <i class="fas fa-angle-right"></i></a></div></div></div><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box-1"><div id="ad-big-box1" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box1');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-e-edition card shadow-sm"><div class="card-header"><i class="fas fa-book-reader"></i> E-edition</div><div class="card-body"><section><div class="ad-image"><a href="https://www.facebook.com/steamboat.Acehardware/"><img width="270" height="40" src="https://cdn.steamboatpilot.com/wp-content/uploads/sites/8/2019/03/web-452686-01-A-270x40-1.jpg" class="attachment-full size-full" alt="" /></a></div> <iframe src="about:blank" style="border: none;" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://edition.pagesuite.com/miniflip/default.aspx?w=150&#038;pages=8&#038;autoflip=4000&#038;PBID=995e7b85-cd95-4a90-9cc5-8b13e4001bd1"></iframe><noscript><iframe src="https://edition.pagesuite.com/miniflip/default.aspx?w=150&pages=8&autoflip=4000&PBID=995e7b85-cd95-4a90-9cc5-8b13e4001bd1" style="border: none;"></iframe></noscript></section></div></div></div><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box-2"><div id="ad-big-box2" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box2');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Happenings Calendar</h5><hr /><div data-cswidget="9419" class="text-center"></div><p><script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" ></script></p></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Top News from the AP</h5><hr /><p><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_6f8022834c110240012e32b15c609e2f" style="overflow: hidden; min-width: 100%; border: none;" src="about:blank" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_6f8022834c110240012e32b15c609e2f');" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://digitalservices.ap.org/widgets/content/6f8022834c110240012e32b15c609e2f"></iframe><noscript><iframe id="iframe_6f8022834c110240012e32b15c609e2f" style="overflow: hidden; min-width: 100%; border: none;" src="https://digitalservices.ap.org/widgets/content/6f8022834c110240012e32b15c609e2f" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_6f8022834c110240012e32b15c609e2f');"></iframe></noscript></p></div></div></div></div></aside></div></div></div></div></main><nav id="nav-mobile-footer" class="fixed-bottom d-lg-none d-xl-none"><ul class="nav nav-fill"><li class="nav-item"> <a class="nav-link " href="https://www.steamboatpilot.com"><i class="fas fa-home icon"></i><br/>Home</a></li><li class="nav-item"> <a class="nav-link " href="https://www.steamboatpilot.com/trending-stories/news/"><i class="fas fa-chart-line icon"></i><br/>Trending</a></li><li class="nav-item"> <a class="nav-link" id="mobile-back-to-top" href="#" class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"><i class="fas fa-bars icon"></i><br/>Sections</a></li></ul></nav><footer><div class="container"><nav id="nav-footer"><div class="row"><div class="col-md-5 offset-md-1 order-md-4"><ul class="nav nav-social justify-content-center justify-content-md-end"><li class="nav-item"><a class="nav-link" href="https://twitter.com/SteamboatPilot" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-twitter icon-circle"></i> <i class="fab fa-twitter fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.facebook.com/SteamboatPilot" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-facebook-f icon-circle"></i> <i class="fab fa-facebook-f fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.instagram.com/steamboatpilot/" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-instagram icon-circle"></i> <i class="fab fa-instagram fa-stack-1x icon-social"></i> </span></a></li></ul></div><div class="col-md-2 nav-list order-md-1"><h6>Marketplace</h6><ul class="nav flex-md-column"><li id="menu-item-334615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334615"><a href="http://classifieds.steamboatpilot.com">Classifieds</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334616"><a href="http://classifieds.steamboatpilot.com/category/Employment">Jobs</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334617"><a href="http://classifieds.steamboatpilot.com/category/Real-Estate-For-Sale">Real Estate</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334618"><a href="http://classifieds.steamboatpilot.com/category/Rentals">Rentals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334619" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334619"><a href="http://classifieds.steamboatpilot.com/category/Transportation">Autos</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334620"><a href="http://classifieds.steamboatpilot.com/category/Pets">Pets</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334621" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334621"><a href="http://classifieds.steamboatpilot.com/category/Recreation">Recreation</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334622"><a href="http://classifieds.steamboatpilot.com/category/Merchandise">Merchandise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334623"><a href="http://classifieds.steamboatpilot.com/category/Legals">Legals</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-2"><h6>Reader Tools</h6><ul class="nav flex-md-column"><li id="menu-item-334632" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334632"><a href="https://www.steamboatpilot.com/contact-us/">Contact Us</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334633"><a href="https://www.steamboatpilot.com/contribute/">Contribute</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334635"><a href="http://www.swiftlocalsolutions.com/advertise-with-steamboat-today">Advertise</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334636"><a href="https://www.steamboatpilot.com/search-results/">Archives</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334631"><a href="https://www.steamboatpilot.com/about-us/">About Us</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-354767" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-354767"><a href="https://www.steamboatpilot.com/newsletters/">Newsletters</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-356327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-356327"><a href="https://marketplace.adpay.com/CMNM/Obituary">Submit an Obituary</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334638" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334638"><a href="http://www.cmnmprinting.com/">Commercial Print Sales</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334639"><a href="https://www.steamboatpilot.com/feed/">RSS</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334640" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334640"><a href="https://www.steamboatpilot.com/eedition/">E-edition</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334641" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334641"><a href="https://www.steamboatpilot.com/e-edition/">E-edition archive</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334642"><a href="https://www.steamboatpilot.com/cookie-list/">Cookie List</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div><div class="col-md-2 nav-list order-md-3"><h6>News Neighbors</h6><ul class="nav flex-md-column"><li id="menu-item-334624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334624"><a href="https://www.aspentimes.com/">Aspen &#8211; Snowmass</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334625"><a href="https://www.craigdailypress.com/">Craig &#8211; Moffat County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334626"><a href="https://www.postindependent.com/">Glenwood Springs &#8211; Rifle</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334627" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334627"><a href="https://www.parkrecord.com/">Park City &#8211; Utah</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334628"><a href="https://www.summitdaily.com">Breckenridge &#8211; Summit County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334629"><a href="https://www.vaildaily.com/">Vail &#8211; Eagle County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li><li id="menu-item-334630" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-334630"><a href="https://www.skyhidailynews.com/">Winter Park &#8211; Granby &#8211; Grand County</a></li><li class="nav-item d-md-none"><span class="nav-divider"> | </span></li></ul></div></div></nav><nav id="nav-footer-sub"><ul class="nav justify-content-center"><li id="menu-item-334916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334916"><a href="https://www.steamboatpilot.com/about-us/">About Us</a><span>|</span></li><li id="menu-item-334910" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334910"><a href="https://www.steamboatpilot.com/terms-of-use/">Terms of Use</a><span>|</span></li><li id="menu-item-334911" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-334911"><a href="https://www.steamboatpilot.com/privacy-policy/">Privacy Policy</a><span>|</span></li></ul><p class="text-center text-muted">©2005 - 2019 Swift Communications, Inc.</p></nav></div></footer> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-1066460699"></script> <script>window.dataLayer = window.dataLayer || [];
					  function gtag(){dataLayer.push(arguments);}
					  gtag('js', new Date());
					  gtag('config', 'AW-1066460699');</script> <script type="text/javascript">var _qevents = _qevents || [];

					(function() {
						var elem = document.createElement('script');
						elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
						elem.async = true;
						elem.type = "text/javascript";
						var scpt = document.getElementsByTagName('script')[0];
						scpt.parentNode.insertBefore(elem, scpt);
						})();

						_qevents.push({
						qacct:"p-a9NnlNKE5Euxo"
					});</script> <noscript><div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-a9NnlNKE5Euxo.gif" border="0" height="1" width="1" alt="Quantcast"/></div> </noscript> <script>jQuery(function($) {
						if ( $( '.wp-audio-shortcode' ).length ) {
							$( 'audio' ).mediaelementplayer({
								success: function(mediaElement, domObject, instance) {
		        			mediaElement.addEventListener('loadeddata', function() {
										ga( 'send', 'event', 'audio', 'play' );
										ga( 'newTracker.send', 'event', 'audio', 'play' );
				        	}, false);
									mediaElement.addEventListener('loadstart', function() {
										$( '.mejs-audio a.audio-download' ).click(function() {
											ga( 'send', 'event', 'audio', 'download' );
											ga( 'newTracker.send', 'event', 'audio', 'download' );
										});
									}, false);
		  					}
							});
						}
					});</script> <script>jQuery(function($) {
						$( '#mobile-app-link' ).click(function () {
							var eventLabel = $(this).attr('title');
							ga( 'send', 'event', 'Mobile App Link', 'Click', eventLabel );
							ga( 'newTracker.send', 'event', 'Mobile App Link', 'Click', eventLabel );
						});
					});</script> <link rel="manifest" href="/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'F84CcHO7oMwvdaaCUROEq17g8Kk9vroKnbar',
					});</script> <link rel="manifest" href="/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'F84CcHO7oMwvdaaCUROEq17g8Kk9vroKnbar',
					});</script><script type='text/javascript'>/* <![CDATA[ */ var pollsL10n = {"ajax_url":"https:\/\/www.steamboatpilot.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/plugins/wp-polls/polls-js-75fa0eff692f3edd7027ca26112ffa21.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/js/vendors/popper-c294535f0ca762f129f01ba29edc48cc.js'></script> <script type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/busting/8/wp-content/themes/swift-news-theme/assets/js/vendors/recliner.min-0.2.3.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-42fe64eae3940b4534418b22f900aa88.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-datepicker-146d8c82affb8e884f24f2a33ad7865a.js'></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.js?ver=3.5.6'></script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/js/vendors/lightslider-0e2674e53f7915be0603741f43cee23e.js'></script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/js/vendors/lightgallery-575b592d9f7c823b42e1a2dfa78c7c11.js'></script> <script type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/busting/8/wp-content/themes/swift-news-theme/assets/js/vendors/if-4-bootstrap-breakpoint.min-1.0.0.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var more_briefs = {"ajaxurl":"https:\/\/www.steamboatpilot.com\/wp-admin\/admin-ajax.php","briefs_nonce":"ef4e30bab4"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://cdn.steamboatpilot.com/wp-content/cache/min/8/wp-content/themes/swift-news-theme/assets/js/main-3d2777a6912c0571c697892db4d3f3ea.js'></script> <script type='text/javascript' src='https://cookie-cdn.cookiepro.com/consent/67c0601c-cbdc-41a3-8810-06ba4edd5bc9.js?ver=1.0'></script> <script type='text/javascript'>function OptanonWrapper() { }</script> <script type='text/javascript' src='https://cdn.steamboatpilot.com/wp-includes/js/wp-embed.min.js'></script> <script>var loggedIn = 'no';
var swiftLanguage = ( accessCookie("swift_language") == null ) ? 'english' : accessCookie("swift_language");
ga('set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'Lisa Schlichtman','dimension7': '','dimension8': '2019-10-28','dimension9': 'wp-356944','dimension10': '','dimension12': '2019-10-28 13:54:59','dimension13': '20','dimension14': 'article','dimension15': '382','dimension16': 'home','dimension18': swiftLanguage});
ga('newTracker.set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'Lisa Schlichtman','dimension7': '','dimension8': '2019-10-28','dimension9': 'wp-356944','dimension10': '','dimension12': '2019-10-28 13:54:59','dimension13': '20','dimension14': 'article','dimension15': '382','dimension16': 'home','dimension18': swiftLanguage});

			ga('provide', 'adblockTracker', function(tracker, opts) {
			  var ad = document.createElement('ins');
			  ad.className = 'AdSense';
			  ad.style.display = 'block';
			  ad.style.position = 'absolute';
			  ad.style.top = '-1px';
			  ad.style.height = '1px';
			  document.body.appendChild(ad);
				var adBlockEnabled = !ad.clientHeight ? 'yes' : 'no';
			  tracker.set('dimension' + opts.dimensionIndex, adBlockEnabled);
			  document.body.removeChild(ad);
			});
			ga('require', 'adblockTracker', {dimensionIndex: 11});
      var currLocation = String(document.location);
      // strip out email addresses from location url
      var emailRegex = /([a-zA-Z0-9_\.-]+)@([\da-zA-Z\.-]+)\.([a-zA-Z\.]{2,6})/i;
      var cleanPageLocation = currLocation.replace(emailRegex, "");

      ga('set', 'location', cleanPageLocation);
			ga('set', 'anonymizeIp', true);
			ga('newTracker.set', 'location', cleanPageLocation);
			ga('newTracker.set', 'anonymizeIp', true);
				ga('send', 'pageview');
				ga('newTracker.send', 'pageview');</script><script>var chartbeatUser = ''
	        var _sf_async_config = _sf_async_config || {};
	        _sf_async_config.uid = 57640; _sf_async_config.domain = 'swiftcom.com'; _sf_async_config.useCanonical = true;
	      	_sf_async_config.sections = 'SteamboatToday.com,news';
	      	_sf_async_config.authors = 'Lisa Schlichtman';
	        _sf_async_config.title = 'Suspects officially charged with 3 felonies in connection with Steamboat man&#8217;s murder | SteamboatToday.com';
	  			var _cbq = window._cbq = (window._cbq || []);
	      	_cbq.push(['_acct', chartbeatUser]);
	        (function(){
	          function loadChartbeat() {
	            window._sf_endpt=(new Date()).getTime();
	            var e = document.createElement('script');
	            e.setAttribute('language', 'javascript');
	            e.setAttribute('type', 'text/javascript');
	            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
	            document.body.appendChild(e);
	          }
	          var oldonload = window.onload;
	          window.onload = (typeof window.onload != 'function') ?
	              loadChartbeat : function() {
	                  oldonload();
	                  loadChartbeat();
	              };
	        })();</script><script>jQuery( window ).on( 'load', function() {
		$( '.video-carousel').on('slide.bs.carousel', function(evt) {
			var videoIFrame = $( 'iframe[allow]', $( '.carousel-item', this)[evt.from] )[0];
			if( videoIFrame && videoIFrame.contentWindow && videoIFrame.contentWindow.postMessage ) {
				videoIFrame.contentWindow.postMessage("pauseplz", "https://player.swiftcom.com");
			}
		});
	});</script> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://cdn.steamboatpilot.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://cdn.steamboatpilot.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img,iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );

	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };

	observer.observe(b, config);
}, false);</script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1572366976 -->